As ns am make the efforts to operation my applications from recently updated Xcode 8 to my iPhone 4 which is to run iOS 7.1.2

It throws below error,

*

And, this is my Xcode version,

*

Has anyone challenged this problem before? Awaiting for your suggestions!!




You are watching: Xcode could not locate device support files

*

*

Actually, there is a way. You simply need come copy DeviceSupport folder for iOS 7.1 from Older Xcode come the new one. It"s located in:

/Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/DeviceSupport/7.1

If friend don"t have the 7.1 records anymore, you have the right to download a previous variation of XCode ~ above https://developer.apple.com/download/more/, extract it, and then copy these records to complying with path

/Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/DeviceSupport/

Credit


*

*

I had actually a similar problem because the application store variation was missing iOS 10.1 assistance in Xcode 8 and also they haven"t rolled an upgrade yet. This led to the "Xcode: could not locate maker support files" problem. You can download the latest upgrade https://developer.apple.com/download/ and also it is more current and also supports iOS 10.1 (14B72c).




See more: The 5 Best Defense To Run In Madden 17 Teams, Madden Nfl 17 Hb Stretch Run Defense

*

I have Xcode 10.1 and I have the right to not run my applications on my maker with 12.2 iOS version.

The easiest solution because that me was:

Go v finder at Xcode locationRight Click -> show Package ContentsContents -> Developer -> communication -> iPhoneOS.platform -> DeviceSupportHere you find a list of sustained version. Select the many recent one and also copy(In my situation was 12.1 (16B91))Paste in the exact same folder(DeviceSupport) and also call it through the version you need.(In my instance was 12.2 (16E227))Close Xcode if you have actually it openReconnect machine if it was connectedOpen Xcode and build

If this trick does no working, you have to obtain the versions indigenous the new Xcode version.

But you can try, saves a most time. An excellent luck!

EDIT: Or you deserve to download your needed device support native here:https://github.com/iGhibli/iOS-DeviceSupport/tree/master/DeviceSupport